18/06/2024

Scubalife.EU

MSDT: #366200

Routing OSPF

General information and attributes

  • Type: Link-State
  • Algorithm: Dijkstra
  • Metric: Cost (Bandwidth)
  • AD: 110
  • Standard: RFC 2328, 2740
  • Protocols: IP
  • Transport: IP/89
  • Authentication: Plaintext, MD5
  • AllSPF Address: 224.0.0.5
  • AllDR Address: 224.0.0.6

Link State Advertisements (LSA):

  • Router Link (Type 1): Lists neighboring routers and the cost to each; flooded within an area
  • Network Link (Type 2): Generated by a DR; lists all routers on an adjacent segment; flooded within an area
  • Network Summary (Type 3): Generated by an ABR and advertised among areas
  • ASBR Summary (Type 4): Injected by an ABR into the backbone to advertise the presence of an ASBR within an area
  • External Link (Type 5): Generated by an ASBR and flooded throughout the AS to advertise a route external to OSPF
  • NSSA External Link (Type 7): Generated by an ASBR in a not-so-stubby area; converted into a type 5 LSA by the ABR when leaving the area

Router Types

  • Internal Router: All interfaces reside within the same area
  • Backbone Router: A router with an interface in area 0 (the backbone)
  • Area Border Router (ABR): Connects two or more areas
  • AS Boundary Router (ASBR): Connects to additional routing domains; typically located in the backbone

Area Types

  • Standard Area: Default OSPF area type
  • Stub Area: External link (type 5) LSAs are replaced with a default route
  • Totally Stubby Area: Type 3, 4, and 5 LSAs are replaced with a default route
  • Not So Stubby Area (NSSA): A stub area containing an ASBR; type 5 LSAs are converted to type 7 within the area

External Route Types

  • E1: cost to the advertising ASBR plus the external cost of the route
  • E2: (Default) – cost of the route as seen by the ASBR
  • metric formula  cost = (100.000kbps/link speed) [modifiable by command:
    ospf auto-cost reference-bandwidth

Troubleshooting

show ip [route | protocols]
show ip ospf interface
show ip ospf neighbor
show ip ospf border-routers
show ip ospf virtual-links
debug ip ospf […]

Configuration examples

Diagram

Router A
interface Serial0/0
description WAN Link
ip address 172.16.34.2 255.255.255.252
!
interface FastEthernet0/0
description Area 0
ip address 192.168.0.1 255.255.255.0
!
interface Loopback0
! Used as router ID
ip address 10.0.34.1 255.255.255.0
!
router ospf 100
! Advertising the WAN cloud to OSPF
redistribute static subnets
network 192.168.0.0 0.0.0.255 area 0
!
! Static route to the WAN cloud
ip route 172.16.0.0 255.255.192.0 172.16.34.1
Router B
interface Ethernet0/0
description Area 0
ip address 192.168.0.2 255.255.255.0
ip ospf 100 area 0
!
interface Ethernet0/1
description Area 2
ip address 192.168.2.1 255.255.255.0
ip ospf 100 area 2
! Optional MD5 authentication configured
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 FooBar
! Give B priority in DR election
ip ospf priority 100
!
interface Ethernet0/2
description Area 1
ip address 192.168.1.1 255.255.255.0
ip ospf 100 area 1
!
interface Loopback0
ip address 10.0.34.2 255.255.255.0
!
router ospf 100
! Define area 1 as a stub area
area 1 stub
! Virtual link from area 0 to area 9
area 2 virtual-link 10.0.34.3
Router C
interface Ethernet0/0
description Area 9
ip address 192.168.9.1 255.255.255.0
ip ospf 100 area 9
!
interface Ethernet0/1
description Area 2
ip address 192.168.2.2 255.255.255.0
ip ospf 100 area 2
! Optional MD5 authentication configured
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 FooBar
! Give C second priority (BDR) in election
ip ospf priority 50
!
!
!
!
!
!
interface Loopback0
ip address 10.0.34.3 255.255.255.0
!
router ospf 100
! Define area 9 as a totally stubby area
area 9 stub no-summary
! Virtual link from area 9 to area 0
area 2 virtual-link 10.0.34.2